No hardware-accelerated Direct3D devices where found.

Allt om Windows XP. Lös problem och ge tips.

Moderator: Imposter10

Inlägg: 1
Blev medlem: 2010-jan-25, 15:38

No hardware-accelerated Direct3D devices where found.

Inlägg av ozonite » 2010-jan-25, 15:40

Ledsen att posten är på engelska jag har postat den på flera forum

Sammanfattning på svenska: Behöver ladda ner direct3D men jag har redan directX installerat.

I play this game (warrock) and when I try to start it the screen goes black and all I can hear is the sound. When I quit there's a message that says:
"No hardware-accelerated Direct3D devices where found."
This has happened very recently and I've been able to play this game for about 4 years.
I've tried to reinstall the game but that doesn't work.
I already have directX 9.0c installed so I can't reinstall it
When I check the Diagnostic tool for DirectX in the display area there is a text saying: Direct3D acceleration: Not available
I've tried downloading WINDOWS service package 2, which I can't get to work
I've tried virus scan

It is not the video card since the game has worked perfectly before

I can't reformat the drive unfortunately since I lost my Windows XP CD.
I'm desperate for a solution.
Could someone please tell me how to reinstall DirectX or how to get Direct3D in some other way
I think the problem was caused when I used a program called regrun which scans your startup and lets you delete possible malware, and I guess I deleted the wrong file.
To sum up: I need to find a way to get Direct3D that
Thanks in advance.

PC Doktor i Stockholm
Inlägg: 1249
Blev medlem: 2009-okt-29, 23:11

Inlägg av PC Doktor i Stockholm » 2010-jan-26, 16:39

Vilken grafikkort har du?
PC Doktor i Stockholm

Skriv svar